$re = '/(?<=\[)[^\[\]]*(?=\])/m';
$str = 'this is the range of values (a1,b1) and [b1|a1]
this is the range of values (a1,b1) and [b2|a2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);