package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bM10[0-9][0-9]\b`)
var str = `M0
M00
M1
M01
M3
M03
M4
M04
M5
M05
M8
M08
M9
M09
M11
M12
M13
M29
M30
M40
M41
M42
M68
M69
M78
M79
M94
M95
M98
M98 P1111 L10
M99
M100
M101
M102
M103
M104
M105
M106
M107
M108
M109
M110
M111
M112
M113
M114
M115
M116
M117
M118
M119
M120
M121
M122
M123
M124
M125
M126
M127
M128
M129
M130
M131
M132
M133
M134
M135
M136
M137
M138
M139
M140
M141
M142
M143
M144
M145
M146
M147
M148
M149
M150
M151
M152
M153
M154
M155
M156
M157
M158
M159
M160
M161
M162
M163
M164
M165
M166
M167
M168
M169
M170
M171
M172
M173
M174
M175
M176
M177
M178
M179
M180
M181
M182
M183
M184
M185
M186
M187
M188
M189
M190
M191
M192
M193
M194
M195
M196
M197
M198
M199
M200
M201
M202
M203
M204
M205
M206
M207
M208
M209
M210
M211
M212
M213
M214
M215
M216
M217
M218
M219
M220
M221
M222
M223
M224
M225
M226
M227
M228
M229
M230
M231
M232
M233
M234
M235
M236
M237
M238
M239
M240
M241
M242
M243
M244
M245
M246
M247
M248
M249
M250
M251
M252
M253
M254
M255
M256
M257
M258
M259
M260
M261
M262
M263
M264
M265
M266
M267
M268
M269
M270
M271
M272
M273
M274
M275
M276
M277
M278
M279
M280
M281
M282
M283
M284
M285
M286
M287
M288
M289
M290
M291
M292
M293
M294
M295
M296
M297
M298
M299
M300
M301
M302
M303
M304
M305
M306
M307
M308
M309
M310
M311
M312
M313
M314
M315
M316
M317
M318
M319
M320
M321
M322
M323
M324
M325
M326
M327
M328
M329
M330
M331
M332
M333
M334
M335
M336
M337
M338
M339
M340
M341
M342
M343
M344
M345
M346
M347
M348
M349
M350
M351
M352
M353
M354
M355
M356
M357
M358
M359
M360
M361
M362
M363
M364
M365
M366
M367
M368
M369
M370
M371
M372
M373
M374
M375
M376
M377
M378
M379
M380
M381
M382
M383
M384
M385
M386
M387
M388
M389
M390
M391
M392
M393
M394
M395
M396
M397
M398
M399
M400
M401
M402
M403
M404
M405
M406
M407
M408
M409
M410
M411
M412
M413
M414
M415
M416
M417
M418
M419
M420
M421
M422
M423
M424
M425
M426
M427
M428
M429
M430
M431
M432
M433
M434
M435
M436
M437
M438
M439
M440
M441
M442
M443
M444
M445
M446
M447
M448
M449
M450
M451
M452
M453
M454
M455
M456
M457
M458
M459
M460
M461
M462
M463
M464
M465
M466
M467
M468
M469
M470
M471
M472
M473
M474
M475
M476
M477
M478
M479
M480
M481
M482
M483
M484
M485
M486
M487
M488
M489
M490
M491
M492
M493
M494
M495
M496
M497
M498
M499
M500
M501
M502
M503
M504
M505
M506
M507
M508
M509
M510
M511
M512
M513
M514
M515
M516
M517
M518
M519
M520
M521
M522
M523
M524
M525
M526
M527
M528
M529
M530
M531
M532
M533
M534
M535
M536
M537
M538
M539
M540
M541
M542
M543
M544
M545
M546
M547
M548
M549
M550
M551
M552
M553
M554
M555
M556
M557
M558
M559
M560
M561
M562
M563
M564
M565
M566
M567
M568
M569
M570
M571
M572
M573
M574
M575
M576
M577
M578
M579
M580
M581
M582
M583
M584
M585
M586
M587
M588
M589
M590
M591
M592
M593
M594
M595
M596
M597
M598
M599
M600
M601
M602
M603
M604
M605
M606
M607
M608
M609
M610
M611
M612
M613
M614
M615
M616
M617
M618
M619
M620
M621
M622
M623
M624
M625
M626
M627
M628
M629
M630
M631
M632
M633
M634
M635
M636
M637
M638
M639
M640
M641
M642
M643
M644
M645
M646
M647
M648
M649
M650
M651
M652
M653
M654
M655
M656
M657
M658
M659
M660
M661
M662
M663
M664
M665
M666
M667
M668
M669
M670
M671
M672
M673
M674
M675
M676
M677
M678
M679
M680
M681
M682
M683
M684
M685
M686
M687
M688
M689
M690
M691
M692
M693
M694
M695
M696
M697
M698
M699
M700
M701
M702
M703
M704
M705
M706
M707
M708
M709
M710
M711
M712
M713
M714
M715
M716
M717
M718
M719
M720
M721
M722
M723
M724
M725
M726
M727
M728
M729
M730
M731
M732
M733
M734
M735
M736
M737
M738
M739
M740
M741
M742
M743
M744
M745
M746
M747
M748
M749
M750
M751
M752
M753
M754
M755
M756
M757
M758
M759
M760
M761
M762
M763
M764
M765
M766
M767
M768
M769
M770
M771
M772
M773
M774
M775
M776
M777
M778
M779
M780
M781
M782
M783
M784
M785
M786
M787
M788
M789
M790
M791
M792
M793
M794
M795
M796
M797
M798
M799
M800
M801
M802
M803
M804
M805
M806
M807
M808
M809
M810
M811
M812
M813
M814
M815
M816
M817
M818
M819
M820
M821
M822
M823
M824
M825
M826
M827
M828
M829
M830
M831
M832
M833
M834
M835
M836
M837
M838
M839
M840
M841
M842
M843
M844
M845
M846
M847
M848
M849
M850
M851
M852
M853
M854
M855
M856
M857
M858
M859
M860
M861
M862
M863
M864
M865
M866
M867
M868
M869
M870
M871
M872
M873
M874
M875
M876
M877
M878
M879
M880
M881
M882
M883
M884
M885
M886
M887
M888
M889
M890
M891
M892
M893
M894
M895
M896
M897
M898
M899
M900
M901
M902
M903
M904
M905
M906
M907
M908
M909
M910
M911
M912
M913
M914
M915
M916
M917
M918
M919
M920
M921
M922
M923
M924
M925
M926
M927
M928
M929
M930
M931
M932
M933
M934
M935
M936
M937
M938
M939
M940
M941
M942
M943
M944
M945
M946
M947
M948
M949
M950
M951
M952
M953
M954
M955
M956
M957
M958
M959
M960
M961
M962
M963
M964
M965
M966
M967
M968
M969
M970
M971
M972
M973
M974
M975
M976
M977
M978
M979
M980
M981
M982
M983
M984
M985
M986
M987
M988
M989
M990
M991
M992
M993
M994
M995
M996
M997
M998
M999
M1000
M1001
M1002
M1003
M1004
M1005
M1006
M1007
M1008
M1009
M1010
M1011
M1012
M1013
M1014
M1015
M1016
M1017
M1018
M1019
M1020
M1021
M1022
M1023
M1024
M1025
M1026
M1027
M1028
M1029
M1030
M1031
M1032
M1033
M1034
M1035
M1036
M1037
M1038
M1039
M1040
M1041
M1042
M1043
M1044
M1045
M1046
M1047
M1048
M1049
M1050
M1051
M1052
M1053
M1054
M1055
M1056
M1057
M1058
M1059
M1060
M1061
M1062
M1063
M1064
M1065
M1066
M1067
M1068
M1069
M1070
M1071
M1072
M1073
M1074
M1075
M1076
M1077
M1078
M1079
M1080
M1081
M1082
M1083
M1084
M1085
M1086
M1087
M1088
M1089
M1090
M1091
M1092
M1093
M1094
M1095
M1096
M1097
M1098
M1099
M1100
M1101
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}