re = /(?<="commit\s)[0-9a-fA-F]{20,}/m
str = 'commit_message = "commit d1099308a1af0f91e93bf22cf6e9b5d294cf121d Author: Martin Date: Wed Apr 17 16:05:35 2019"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end