$re = '/\d(?=(\d{3})+$)/';
$str = '1323232.32323223';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);