package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(bar)(.*?)(baz|$)`)
var str = `baranything
baranythingbaz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}