re = /(?i)^(?!.{16})^.+[.](?:asf|avi|csv|pdf|doc|docx|dot|eml|gif|htm|html|idx|tif|jpg|jpeg|bmp|png|mp3|mpg|msg|ppt|pptx|pst|rtf|txt|wav|wma|xls|xlsx|zip)$/m
str = '12345678901.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end