import Foundation
let pattern = #"(?<=\((No.\)) : )(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CÔNG TY TNHH GRAB
Địa chỉ (Address) :Tòa nhà Mapletree Business Centre, 1060 Nguyễn Văn Linh, Phường Tân Phong, Quận 7,
Thành phố Hồ Chí Minh, Việt Nam
Mã số thuế (Tax code) :0 3 1 2 6 5 0 4 3 7
HÓA ĐƠN GIÁ TRỊ GIA TĂNG
(VAT INVOICE) Ký hiệu (Serial) : 1C22TGN
Ngày (Date) 23 tháng (month) 05 năm (year) 2022 Số (No.) : 1117609
Mã của CQT: 00AD14CC7603364466BF60F761D05D6A13
Họ tên người mua hàng (Customer's name) :
(Xuất bởi phần mềm EInvoice, Công ty TNHH Phát triển công nghệ Thái Sơn - MST: 0101300842 - www.einvoice.vn)
Tên đơn vị (Company) :CÔNG TY TNHH UN-AVAILABLE
Mã số thuế (Tax code) :0303271471
Địa chỉ (Address) :Một phần lô I/3 Đường số 7, Khu công nghiệp Vĩnh Lộc, Phường Bình Hưng Hòa B, Quận Bình Tân,
TP Hồ Chí Minh, Việt Nam
Hình thức thanh toán (Payment term) :Chuyển khoản Số tài khoản (Bank A/C) :
STT Tên hàng hóa, dịch vụ ĐVT Số lượng Đơn giá Thuế suất Thành tiền Tiền thuế Thành tiền
trước thuế
(No.) (Description) (Unit) (Quantity) (Unit Price) (Tax rate) (Amount exc VAT) (VAT amount) (Selling price)
A B C D E F G = I / (1+ F) H = I - G I
Cước phí vận chuyển mã
1 A-3ENBVDNWWJFL Chuyến 1 9.091 10% 9.091 909 10.000
(phần doanh thu Grab
được chia)
Cước phí vận chuyển mã
2 A-3ENBVDNWWJFL Chuyến 1 36.364 10% 36.364 3.636 40.000
(phần doanh thu của đối
tác vận tải)
Tổng cộng số tiền đã có thuế GTGT: 50.000
(Total of VAT included selling price) :
Tổng tiền trước thuế 10%: 45.455 Tổng tiền thuế 10%: 4.545
(Total of amount exc VAT 10%) (Total of VAT amount 10%)
Trong đó: Tổng tiền trước thuế 5%: Tổng tiền thuế 5%:
(in which) (Total of amount exc VAT 5%) (Total of VAT amount 5%)
Tổng cộng số tiền trước thuế: 45.455 Tổng tiền thuế GTGT: 4.545
(Total of amount exc VAT) (Total of VAT amount)
Số tiền viết bằng chữ (Amount in words) : Năm mươi nghìn đồng
Người mua hàng (Buyer) Người bán hàng (Seller)
(Ký, ghi rõ họ tên) (Ký, đóng dấu, ghi rõ họ tên)
(Signature & full name) (Signature, stamp & full name)
Signature Valid
Ký bởi: CÔNG TY TNHH GRAB
Ký ngày: 23/05/2022
Mã nhận hóa đơn (Code for checking): QIEJWLAEYGQ5 tra cứu tại (Tracking): https://vn.invoice.grab.com/
Ghi chú: Thành tiền (giá bán) là giá đã bao gồm thuế GTGT. (Note: Selling price is VAT included)
(Cần kiểm tra, đối chiếu khi lập, giao, nhận hóa đơn / Need to check, compare when making, delivering, receiving invoices)
Trang 1/1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)