$re = '`\[([^\]]*)\]`';
$str = '1 [abc] 2 [def] 3 [ghi] 4 [klm] 5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);