re = /([0-9]{3})\)?\s*[-. ]?\s*([0-9]{3})\s*[-. ]?\s*([0-9]{4})\s*/
str = '555-555-5555 (555)555-5555 (555) 555-5555
555 -555-5555 (555)555- 5555 (555) 555 -5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end