re = /(?:^(?=\w+(?::\w+)+$)|\G(?!^):)\K\w+/m
str = 'apple:banana:cherry:durian
test
test!
!test
a:b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end