re = /^[\w!#$%&'*+\/=?`{|}~^-]+(?:\.[\w!#$%&'*+\/=?`{|}~^-]+)*@(?:[A-Z0-9-]+\.)+[A-Z]{2,6}/i
str = 'edwin.allen@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end