re = /\s*([^\[\]\s]+?)\/([^\[\]\s]+)\s*/
str = '[ Pierre/NNP Vinken/NNP ]
,/,
[ 61/CD years/NNS ]
old/JJ ,/, will/MD join/VB
[ the/DT board/NN ]
as/IN
[ a/DT nonexecutive/JJ director/NN Nov./NNP 29/CD ]
./.
[ Mr./NNP Vinken/NNP ]
is/VBZ
[ chairman/NN ]
of/IN '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end