const regex = new RegExp('(?P<l>\\d+(\\,\\d+)?)\\s*x\\s*(?P<w>\\d+(\\,\\d+)?)\\s*x\\s*(?P<h>\\d+(\\,\\d+)?)', 'g')
const str = `23,6 x 34 x 17,1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}