$re = '/\bjam\s?\d?\b/m';
$str = 'Custard 1
Custard 1 jam
stuff
stuff jam
jam 2
2 jam 47
Custard 1 jam jam2
jam jam
Custard 1 jam jam jam
jamjamjam
jam
14 fluorojam.
pajama.
jammer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);