import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^-](\\p{sc=Han}+$|[-а-яА-Я]+|[-a-zA-Z]+)[^-]$";
final String string = "你妳好12312\n"
+ "第三方\n"
+ "阿伱斯顿АквsSукпП\n"
+ "阿斯Фа фФвSsыв\n"
+ "Yury1\n"
+ "Test\n"
+ " Test\n"
+ "Иванов\n"
+ "Иванов-Петр\n"
+ "Иванов-\n"
+ "фФвSsыв\n"
+ "S1f你好jd\n"
+ "S1f 你好jd\n"
+ "Юрий-\n"
+ "-Юрий\n"
+ "Let-12\n"
+ "Abc-\n"
+ "-Abc\n"
+ "Abc-de";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}