re = /\[([^\]\[\r\n]*)\]/m
str = 'This is a [sample] string with [some] special words. [another one]
This is a [sample string with [some special words. [another one
This is a [sample[sample]] string with [[some][some]] special words. [[another one]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end