$re = '/{[^{}]*}\K,(?=\w)/m';
$str = 'products{id,name},articles{title,text}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);