re = /(?:^(?=[^.]+(?:\.[^.]+)+$)|\G(?!^))\.?([^\][.]+)(?:\[(\d+)\])?/m
str = 'b.c[2].d[123].e1[4].f88[5]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end