re = /(?:(?:\+?[01][\-\s.]*)?(?:[\(]?\d{3}[\-\s.\)]*)?\d{3}[\-\s.]*\d{4})/
str = '231358523423423421162'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end