import re
regex = re.compile(r"(?<=\,)\d{2}")
test_str = ("http://regexr.com\n"
" \n"
" \n"
"Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!\n\n"
"Edit the Expression & Text to see matches. Roll over – matches – or the expression for details. Undo mistakes with cmd-z. Save Favorites & Share $33 expressions with «friends or the Community. Explore your results with Tools. A full Reference & Help is available $2 in the Library, or watch the video Tutorial.\n\n"
"année 201, années 1969 à 1974, – anné 2015, mois 2013\n"
" \n"
"Voici un -deuxième- paragraphe, avec – ÉT “retour” « régulier ».\n"
"Une clause clause inefficace suivi d’une autre clause.\n"
"La suite du texte se — poursuit toujours — normalement.\n\n"
"Voici un autre paragraphe avec un retour forcé (shift return).\n"
"Nous verrons comment les GREP saisiront cette donnée.\n\n"
"Les GREPs sont intégrés dans ces 2 applications — InDesign et Dreamweaver!\n"
"InDesign,InDesign 2.0, “InDesign CS” and InDesign CS2\n"
"The quick brown fox jumps up and down.\n"
"abc abc abc abc\n"
"BONJOUR SOLEIL.\n"
" \n"
" Tot, tot, Toto, toto, totoo, totoooo, tatoo, tato, teratatotinotto\n\n"
"• $22.999, 23,99$, 19.99 $\n"
"$2.99, 22,99$, 2,99$, 2,99 $\n"
"2.53%, 20%\n"
"1.89L, 1,89 L — 2 pour 1$\n"
"514-123-4567 \n"
"• h4N 1X7\n"
"• h8t\n"
"• h4N1X72 Ajout code postal\n"
"• h8T\n"
"mot à trouver\n"
"Charles ixv\n"
"1/3, 234/56\n"
" \n"
"12h22, 12:00, 12am, 12 pm, 11h30 am, 8 PM, 6H15, 08:00, 6.00 pm\n"
"année 2017, années 1970 à 1974, anné 2016, mois 2014\n"
"22/11/2016, 01-08-2017, 01|02|2015, 20.12.2014, 2/3/2012\n"
" \n"
"Sample text for testing:\n"
"SAMPLE\n"
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n\n"
"0123456789 _+-.,!@#$%^&*();\\/|<>”’\n"
"12345 -98.7 3.141 .6180 9,000 +42\n"
"1234 - 5678, 1234 - 1234\n"
"3oF, -10oC\n"
" \n"
"555.123.4567 +1-(800)-555-2468\n"
"(123)-(456)-(7890)\n"
"(xxx (xxx) xxxxx (xx) xxx)\n"
"foo@demo.net bar.ba@test.co.uk\n"
"good4you@yummy.com\n"
"somebody@somewhere.ca, another.somebody@coucouland.com\n"
"www.demo.com http://foo.co.uk/\n"
"http://regexr.com/foo.html?q=bar\n"
"https://mediatemple.netx\n"
" \n"
"76 g ou/or 85 g\n"
" 22,99 ch./ ea.\n"
"22.99\n"
"222,22\n"
"2,222\n"
"22,222 22,\n"
",11,\n"
"22,22$\n"
"22,22 $\n"
"195 ml, 273 ml ou/or 198 g \n"
"1 $\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")