$re = '/>[^>]+?\(\d\)/';
$str = '>fir5t W0rd$ > $ec0nd here(2) >third here()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);