using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]*gallery-image-border"">[^>]*content=""(?<url>[^""]*)""";
string input = @"<div id=""gallery-image-border""> <meta itemprop=""image"" content=""http://img.rnudah.com/images/04/044707022491864.jpg""> <span class=""trackable favourite-heart favourite-heart-empty"" aria-hidden=""true"" data-list-id=""52002304"" data-company-ad=""0"" data-category=""4160"" data-region=""7"" data-event_type=""view"" data-event_name=""save_favourite_ad"" data-page_name=""Add Favourite Ad"" data-xtn2=""5"" data-xiti_f1=""4160"" data-xiti_f2=""7"" data-xiti_f3=""2"" data-xiti_f4=""2"" data-xiti_f5=""248""></span> <div class=""heart-icon-tip adview-tip""> <div class=""arrow-tip""></div> <div class=""tip-content""> Click on the heart to add this to your Favourite list. </div> </div> <div id=""gallery-image-container""><span><a href=""javascript:void(0)"" onclick=""gallery.nextImage()""><img src=""http://img.rnudah.com/images/04/044707022491864.jpg"" style=""margin-top:44px;margin-left:0px""></a></span></div> </div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}