import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^<>](?![^<]*>|[^<>]*<\\/)(?!\\s\\#\\s)(\\#\\S[^<>](?![^<]*>|[^<>]*<\\/)(.*?)\\S\\#)";
final String string = "With # : #Zhong Lun Law Firm#\n\n"
+ "With # : #Algeria’s new Investment Law#\n\n"
+ "With # : #中伦律师事务所#\n\n"
+ "With # : #Victor I-Hsiu Chang#\n\n"
+ "With # : #叶姝欐#\n\n"
+ "With # : #Nguyen Anh Tuan#\n\n"
+ "With # : #AnJie Law Firm#\n\n"
+ "With # : #锦天城律师事务所#\n\n"
+ "<section id=\"Capital\" class=\"vantage-bg-grey\">\n"
+ "<p id=\"Capital\" class=\"DOTY_DOTY-Number\" style=\"background-color: #ec1c24; color: #ffffff; font-weight: bold; font-size: 20px; padding: 5px; text-align: justify;\"><a style=\"color: white;\" href=\"#Capital\"><u>CAPITAL MARKETS</u></a></p><section id=\"Capital\" class=\"vantage-bg-grey\">\n"
+ "<p id=\"Capital\" class=\"DOTY_DOTY-Number\" style=\"background-color: #ec1c24; color: #ffffff; font-weight: bold; font-size: 20px; padding: 5px; text-align: justify;\"><a style=\"color: white;\" href=\"#Capital\"><u>CAPITAL MARKETS</u></a></p><section id=\"Capital\" class=\"vantage-bg-grey\">\n"
+ "<p id=\"Capital\" class=\"DOTY_DOTY-Number\" style=\"background-color: #ec1c24; color: #ffffff; font-weight: bold; font-size: 20px; padding: 5px; text-align: justify;\"><a style=\"color: white;\" href=\"#Capital\"><u>CAPITAL MARKETS</u></a></p><section id=\"Capital\" class=\"vantage-bg-grey\">\n"
+ "<p id=\"Capital\" class=\"DOTY_DOTY-Number\" style=\"background-color: #ec1c24; color: #ffffff; font-weight: bold; font-size: 20px; padding: 5px; text-align: justify;\"><a style=\"color: white;\" href=\"#Capital\"><u>CAPITAL MARKETS</u></a></p>\n\n"
+ "one <p>two</p> three <p class=\"test\">four</p> five <a>six</a> seven <p> eight nine <p/> ten\n\n"
+ "<a style=\"text-decoration: none;\" href=\"https://beta2.law.asia/china/china-top-lawyers-2022/\"><button style=\"width: 100%; font-size: 18px; letter-spacing: 1px; padding: 14px 20px; color: #666; border-color: #F4F4F4; background-color: #fff; background-image: linear-gradient(to bottom,rgba(0,0,0,.01) 0,rgba(0,0,0,.02) 100%); background-repeat: repeat-x; border-radius: 5px; a: hover{background-color:#000;\"><span style=\"color: #c94f3f; font-weight: bold; text-transform: uppercase;\">China</span></button> </a>\n\n"
+ "[vc_column_text]<a style=\"text-decoration: none;\" href=\"https://beta2.law.asia/asia/lawyers/singapore-lawyers/\"><button style=\"width: 100%; font-size: 18px; letter-spacing: 1px; padding: 14px 20px; color: #666; border-color: #F4F4F4; background-color: #fff; background-image: linear-gradient(to bottom,rgba(0,0,0,.01) 0,rgba(0,0,0,.02) 100%); background-repeat: repeat-x; border-radius: 5px; a: hover{background-color:#000;\"><span style=\"color: #c94f3f; font-weight: bold; text-transform: uppercase;\">Singapore</span></button> </a>[/vc_column_text][/vc_column][vc_column width=\"1/2\"][vc_column_text]\n\n\n\n"
+ "[vc_column_text]<a style=\"text-decoration: none;\" href=\"https://beta2.law.asia/asia/lawyers/singapore-lawyers/\"><span style=\"color: #c94f3f; font-weight: bold; text-transform: uppercase;\">Singapore</span></a>[/vc_column_text][/vc_column][vc_column width=\"1/2\"][vc_column_text]\n\n"
+ "<a href=\"https://beta2.law.asia/law-firm/drew-napier/\">Drew & Napier</a><br>\n"
+ "Drew & Napier<br>\n"
+ "<a href=\"https://beta2.law.asia/law-firm/allen-overy/\">Allen & Overy</a><br>\n"
+ "Allen & Overy<br>\n"
+ "<a href=\"https://beta2.law.asia/asia/\">Robert Hasan</a><br>\n"
+ "Robert Hasan<br>\n"
+ "华进律师事务所<br>\n"
+ "华进律师事务所<br>\n"
+ "<a href=\"https://beta2.law.asia/law-firm/deep-far-attorneys-at-law/\">Deep & Far</a><br>\n"
+ "Deep & Far\n"
+ "#<a href=\"https://beta2.law.asia/law-firm/drew-napier/\">Drew & Napier</a>#";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}