# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*\s[0-9]{2}:[0-9]{2}\s+).*(9[4-9]( *[0-9]){6})/$1 $2 $3 $4/gm;t' <<< "20/10/2022 19:00 test 1 99 435 18 1 more text
20/10/2022 20:00 test 2 97 123 1 81 more text2
20/10/2022 21:00 test 3 96 4 3 5567 more text3
20/10/2022 22:00 test abc 2134 4 99 43 51 81 more text4"