$re = '/^\s*<string\s*name="string_name">(?![^<]{5,10}<)([^<].*?)</';
$str = '<string name="string_name">01234567890</string>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);