$re = '/\d*\.?\d+(?:/\d*\.?\d+)*(?:\s+(?:and|to)\s+\d*\.?\d+(?:/\d*\.?\d+)*)*/m';
$str = 'He is 1 and 1/2 years old. He is .5 years old and he is 5 years old. He is between 9 to 11 or 9 to 9 and 1/2. He was born 11/12/20
Score 1 and 2 sometimes, often 1 and 1/2, or 2.5 or 3 and 1/3.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);