package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a.*?\[monitory\].*?href=["|']([http:|https:]?)([\/\/]?)(.*?)["|']>`)
var str = `<a [monitory] href="http://www.link1.com">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}