$re = '/(?<=\[).+(?=\])/';
$str = '[1140851706] D:\\PATH TO\\FILE.PDF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);