package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^_]*_){2}([^_]*)`)
var str = `ABC123_DEF456_GHI789-JKL274`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}