# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n\s*[\w\s\.?äöüÄÖÜß\-?]+\n[\s*^GEB$|\s*^ADR$]"
test_str = (" 2 blabla: 1/2\n"
" Title. Surname-AlsoPartOfTheName Lastname\n"
" GEB: 1111-00-00 ADR: addr ress 00, town 0000\n"
" a 0000/0000 blablabla 0000-00-00, Urkunde 0000-00-00, blabla\n"
" 0000-00-00 blabla\n"
" b 0000/0000 blabla\n"
" c 0000/0000 blabla\n"
" d blabla\n"
" 3 blabla: 1/2\n"
" Title. Surname MiddleName Lastname\n"
" GEB: 0000-00-00 ADR: addr res 00, town 0000\n"
" a 0000/0000 blabla 0000-00-00, blabla 0000-00-00, blabla\n"
" 0000-00-00 blabla\n"
" b 0000/0000 blabla\n"
" c 0000/0000 blabla\n"
" d blabla")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.