$re = '/\{([^}]+)(?:\(([^)]+)\))?\}/';
$str = 'Invoice Date: {InvoiceDate(dd.mm.YYYY)}
Inoice Number: {InvoiceNumber}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);