$re = '~^(.*)~m';
$str = 'wp-content/uploads/2020/01/img.gif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);