package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\u0E00-\u0E7F]+)`)
var str = `engภาษาไทยที่มีสระ123!@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}