# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^REMARK[^\r\n]+([\r\n]+)@ID"
test_str = ("[H[2JLIST F.PROTOCOL @ID PROTOCOL.ID PROCESS.DATE TIME.MSECS K.USER APPLICATION LEVEL.FUNCTION ID REMARK PAGE 1 11:34:02 23 NOV 2023\n\n"
"@ID............ 202309260081340532.21\n"
"@ID............ 202309260081340532.21\n"
"PROTOCOL.ID.... 202309260081340532.21\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:15:32:934\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202309260081340523.16\n"
"@ID............ 202309260081340523.16\n"
"PROTOCOL.ID.... 202309260081340523.16\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:15:23:649\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202309260081340465.12\n"
"@ID............ 202309260081340465.12\n"
"PROTOCOL.ID.... 202309260081340465.12\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:14:25:781\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ AUTHORISER-8232\n"
"@ID............ AUTHORISER-8232\n"
"PROTOCOL.ID.... AUTHORISER-8232\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 09:08:19:962\n"
"K.USER......... AUTHORISER\n"
"APPLICATION.... PGM.BREAK\n"
"LEVEL.FUNCTION. 1\n"
"ID............. [H[2JLIST F.PROTOCOL @ID PROTOCOL.ID PROCESS.DATE TIME.MSECS K.USER APPLICATION LEVEL.FUNCTION ID REMARK PAGE 2 11:34:02 23 NOV 2023\n\n"
"REMARK.........\n\n"
"@ID............ 202309260081340530.06\n"
"@ID............ 202309260081340530.06\n"
"PROTOCOL.ID.... 202309260081340530.06\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:15:30:223\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202309269535047401.01\n"
"@ID............ 202309269535047401.01\n"
"PROTOCOL.ID.... 202309269535047401.01\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 13:10:01:201\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... DRAWINGS\n"
"LEVEL.FUNCTION. 1 I\n"
"ID.............\n"
"REMARK.........\n\n"
"@ID............ 202309260081340469.10\n"
"@ID............ 202309260081340469.10\n"
"PROTOCOL.ID.... 202309260081340469.10\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:14:29:654\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202309260081340490.06\n"
"@ID............ 202309260081340490.06\n"
"PROTOCOL.ID.... 202309260081340490.06\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:14:50:299\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY [H[2JLIST F.PROTOCOL @ID PROTOCOL.ID PROCESS.DATE TIME.MSECS K.USER APPLICATION LEVEL.FUNCTION ID REMARK PAGE 3 11:34:02 23 NOV 2023\n\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202309260081340509.05\n"
"@ID............ 202309260081340509.05\n"
"PROTOCOL.ID.... 202309260081340509.05\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:15:09:201\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202309260081340529.00\n"
"@ID............ 202309260081340529.00\n"
"PROTOCOL.ID.... 202309260081340529.00\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:15:29:015\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202310033834745376.01\n"
"@ID............ 202310033834745376.01\n"
"PROTOCOL.ID.... 202310033834745376.01\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 12:36:16:380\n"
"K.USER......... ASHWIN.KUMAR\n"
"APPLICATION.... CATEGORY\n"
"LEVEL.FUNCTION. 1 S\n"
"ID.............\n"
"REMARK.........\n\n"
"@ID............ 202309260081340496.06\n"
"@ID............ 202309260081340496.06\n"
"PROTOCOL.ID.... 202309260081340496.06\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 11:14:56:370 [H[2JLIST F.PROTOCOL @ID PROTOCOL.ID PROCESS.DATE TIME.MSECS K.USER APPLICATION LEVEL.FUNCTION ID REMARK PAGE 4 11:34:02 23 NOV 2023\n\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... AC.INWARD.ENTRY\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK......... ENQUIRY - AC.INTERFACE.REPORT\n\n"
"@ID............ 202310031395145227.00\n"
"@ID............ 202310031395145227.00\n"
"PROTOCOL.ID.... 202310031395145227.00\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 12:33:47:173\n"
"K.USER......... ASHWIN.KUMAR\n"
"APPLICATION.... SIGN.ON\n"
"LEVEL.FUNCTION.\n"
"ID.............\n"
"REMARK.........\n\n"
"@ID............ TEST1-70226\n"
"@ID............ TEST1-70226\n"
"PROTOCOL.ID.... TEST1-70226\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 12:52:55:808\n"
"K.USER......... TEST1\n"
"APPLICATION.... PGM.BREAK\n"
"LEVEL.FUNCTION. 1\n"
"ID.............\n"
"REMARK.........\n\n"
"@ID............ 202309264115451975.00\n"
"@ID............ 202309264115451975.00\n"
"PROTOCOL.ID.... 202309264115451975.00\n"
"PROCESS.DATE... 20230926\n"
"TIME.MSECS..... 14:26:15:315\n"
"K.USER......... INPUTTER\n"
"APPLICATION.... ENQUIRY.SELECT\n"
"LEVEL.FUNCTION. 1\n"
"ID............. TRADE.POS.VALUATION_BH0010001_INPUTTER\n"
"REMARK......... 1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.