$re = '/([a-z]+).([a-z]{2,4})$/';
$str = 'widget.judge.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);