# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[|){\n(?<tab> )\"id\": \"[0-9]*\",\n\<tab>\"type\": [0-9],\n\<tab>\"content\": \"[^\"]*\",\n\<tab>\"channel_id\": \"[0-9]*\",\n\<tab>\"author\": {\n(?<dtab> )\"id\": \"[^\"]*\",\n\<dtab>\"username\": \"[^\"]*\",\n\<dtab>\"avatar\": \"[^\"]*\",\n\<dtab>\"discriminator\": \"([0-9]{4}|[0-9])\",\n\<dtab>\"public_flags\": [0-9]*,\n\<dtab>\"flags\": [0-9]*,\n\<dtab>\"banner\": (null|\"[0-9]*\"),\n\<dtab>\"accent_color\": (null|\"[^\"]*\"),\n\<dtab>\"global_name\": \"[^\"]*\",\n\<dtab>\"avatar_decoration_data\": (null|\"[^\"]*\"),\n\<dtab>\"banner_color\": (null|\"[^\"]*\")\n\<tab>},\n\<tab>\"attachments\": \[[^\]]*\],\n\<tab>\"embeds\": \[[^\]]*],\n\<tab>\"mentions\": \[[^\]]*],\n\<tab>\"mention_roles\": \[[^\]]*\],\n\<tab>\"pinned\": (true:|false),\n\<tab>\"mention_everyone\": (true|false),\n\<tab>\"tts\": (true:|false),\n\<tab>\"timestamp\": \"[0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{6}\+[0-9]{2}:[0-9]{2}\",\n\<tab>\"edited_timestamp\": (null|\"[0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{6}\+[0-9]{2}:[0-9]{2}\"),\n\<tab>\"flags\": [0-9]*,\n\<tab>\"components\": \[[^\]]*]\n}(\]|\,|)"
test_str = ("{\n"
" \"id\": \"1145344233713188874\",\n"
" \"type\": 0,\n"
" \"content\": \"913 - this icecream good\",\n"
" \"channel_id\": \"1124414874454339715\",\n"
" \"author\": {\n"
" \"id\": \"746383273621717104\",\n"
" \"username\": \"kalote.\",\n"
" \"avatar\": \"95b9bdc7aa5784a2354e2ec5256ae736\",\n"
" \"discriminator\": \"0\",\n"
" \"public_flags\": 128,\n"
" \"flags\": 128,\n"
" \"banner\": null,\n"
" \"accent_color\": null,\n"
" \"global_name\": \"Carrot :3\",\n"
" \"avatar_decoration_data\": null,\n"
" \"banner_color\": null\n"
" },\n"
" \"attachments\": [],\n"
" \"embeds\": [],\n"
" \"mentions\": [],\n"
" \"mention_roles\": [],\n"
" \"pinned\": false,\n"
" \"mention_everyone\": false,\n"
" \"tts\": false,\n"
" \"timestamp\": \"2023-08-27T13:09:04.784000+00:00\",\n"
" \"edited_timestamp\": null,\n"
" \"flags\": 0,\n"
" \"components\": []\n"
"},")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.