$re = '/^[a-z](?!\-\-)[0-9_a-z\-]*[0-9a-z]$/m';
$str = 'foo-bar
foo--bar
foo_bar
foo__bar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);