$re = '/OPNTMO Nr ([0-9]+)/m';
$str = 'OPNTMO Nr 26';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);