import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bdiscount\\h[^\\r\\n€]*\\K€\\d{1,2}(?:,\\d{1,2})?\\b";
final String string = "discount of €50,20 on these items €\n"
+ "This item on sale now for €30,20";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}