$re = '/^([^,]+)\s+\S+,/m';
$str = 'street name 123, postal code city, country
street name only, postal code city, country';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);