import re
regex = re.compile(r"^(PO BOX|BOX)+\s*[A-Z]?[0-9]+[A-Z]*\s.*$", flags=re.MULTILINE)
test_str = ("BOX ELDER CT\n"
"PO BOX 111 \n"
"PO BOX 191 \n"
"39TH ST\n"
"6TH ST\n"
"4TH AVE\n"
"5TH AVE\n"
"5TH ST\n"
"2ND AVE\n"
"15TH AVE\n"
"BOX ELDER DR\n"
"PO BOX 297 \n"
"PO BOX 42 \n"
"PO BOX 18 \n"
"PO BOX 16 \n"
"PO BOX 115A \n"
"PO BOX 245 \n"
"PO BOX 131 \n"
"PO BOX 254 \n"
"PO BOX 254 \n"
"PO BOX 49B \n"
"PO BOX 373 \n"
"PO BOX 178 \n"
"PO BOX 245 \n"
"PO BOX 51 \n"
"PO BOX 400 \n"
"PO BOX 25 \n"
"PO BOX 25 \n"
"PO BOX 7 \n"
"PO BOX 97 \n"
"PO BOX 363 \n"
"PO BOX 482 \n"
"PO BOX 24 \n"
"PO BOX 55 \n"
"PO BOX 204 \n"
"PO BOX 482 \n"
"PO BOX 331 \n"
"PO BOX 99 \n"
"PO BOX 204 \n"
"PO BOX 224C \n"
"BOX 246 \n"
"BOX 2005 \n"
"BOX 431 ATLAN & CLEV \n"
"BOX 384 \n"
"BOX 22 \n"
"BOX 247 \n"
"BOX 212 \n"
"BOX 85 \n"
"PO BOX 192 \n"
"PO BOX 192 \n"
"BOX 232 \n"
"BOX 28 \n"
"PO BOX A73 \n"
"PO BOX 53 \n"
"BOX 4 \n"
"PO BOX 266 \n"
"BOX 154 \n"
"BOX 261 \n"
"BOX 82 \n"
"BOX ELDER LN\n"
"BOX 101 \n"
"PO BOX 76 EAST MARKET ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")