#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*(?<!_[0sml])\.jpg$"
Local $sString = "9Uikt/ifehr54mg__0.jpg" & @CRLF & _
"9Uikt/idg4hdmg2_s.jpg" & @CRLF & _
"9Uikt/igdffgggfmg4_m.jpg" & @CRLF & _
"9Uikt/img3teg3gegg7_l.jpg" & @CRLF & _
"9Uikt/imgerhw45h70.jpg" & @CRLF & _
"9Uikt/imggq4ge37s.jpg" & @CRLF & _
"9Uikt/img3f37m.jpg" & @CRLF & _
"9Uikt/img34g3f7l.jpg" & @CRLF & _
"9Uikt/imgf3f34t4t73l_.jpg" & @CRLF & _
"9Uikt/imgf3f34t4t73l_2.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")