using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\d{1,3}(,\d{3})*(\.\d+)?)|(\d+(\.\d+)?))$";
string input = @"0,999,999,999,999,999.0
10,999,999,999,999,9899.9
99,999
9.99
9.9
999,99
9,999
999.0
abc123
66666666666666666666.098
888888888
0.999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}