#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:https?|ftp):\\?\/\\?\/sun2.[^\s\,]+"
Local $sString = "<a aria-label="фотография" onclick="return showPhoto('-100714248_457263531', 'wall-100714248_195733', {"temp":{"x":"https:\/\/sun1.tattelecom-nbc.userapi.com\/AZsv8R78JOlrmsTJ6NR_NZpKj-RbfbWCPWQ8uA\/QnMLGnxpnYk.jpg","y":"https:\/\/sun1.tattelecom-nbc.userapi.com\/vtKcPNt6Wazn_vcPkvLAMX1MOhMz_hfRgYx28g\/cXJNEGEn2Lc.jpg","z":"https:\/\/sun2.tattelecom-nbc.userapi.com\/oZ0evVUqXklp4UGCisHHFRSaNTEfnnJO_A7lTg\/ZqD22JRrSyw.jpg","x_":["https:\/\/sun1.tattelecom-nbc.userapi.com\/AZsv8R78JOlrmsTJ6NR_NZpKj-RbfbWCPWQ8uA\/QnMLGnxpnYk",359,604],"y_":["https:\/\/sun1.tattelecom-nbc.userapi.com\/vtKcPNt6Wazn_vcPkvLAMX1MOhMz_hfRgYx28g\/cXJNEGEn2Lc",480,807],"z_":["https:\/\/sun2.tattelecom-nbc.userapi.com\/oZ0evVUqXklp4UGCisHHFRSaNTEfnnJO_A7lTg\/ZqD22JRrSyw",587,987],"base":""},"queue":1}, event)" style="width: 68px; height: 115px;background-image: url(https://sun2.tattelecom-nbc.userapi.com/aMS3yYlzjZF3H6GPY1T5oDAeIqZD5uQv4WveMw/7ToUPNMTnmo.jpg);" class="page_post_thumb_wrap image_cover page_post_thumb_last_column fl_l page_post_thumb_not_single" data-photo-id="-100714248_457263531"></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")