package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)\.{4,}`)
var str = `asdf....... `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}