#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z]+(?![a-z])|[A-Z][a-z]*"
Local $sString = "SalaryGrade" & @CRLF & _
"ParentChild" & @CRLF & _
"Maintenance" & @CRLF & _
"RemittanceSPD" & @CRLF & _
"FBIAgent" & @CRLF & _
"FBIAgentNYDepartment"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")