using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(product)(\s+)((?:(?!cat1|cat2).)+)";
string input = @"product product name cat1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}