#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<KEY>[^=#\s]+)=(?P<VALUE>.*)$"
Local $sString = "app=tcp/444" & @CRLF & _
"# Catchs only Key:app Value:tcp > should catch Key:app Value:tcp/444 " & @CRLF & _
"" & @CRLF & _
"catdt=Network-based " & @CRLF & _
"# Current result: " & @CRLF & _
"# catdt:'Network'" & @CRLF & _
"# " & @CRLF & _
"# Shoud be:" & @CRLF & _
"# catdt:'Network-based' " & @CRLF & _
"" & @CRLF & _
"eventId=123123 externalId=11111" & @CRLF & _
"# Current result:" & @CRLF & _
"# eventId:'123123 externalId=11111'" & @CRLF & _
"#" & @CRLF & _
"# Should catch" & @CRLF & _
"# eventId: '123123'" & @CRLF & _
"# externalId: '111111'" & @CRLF & _
"" & @CRLF & _
"src=2.3.4.5" & @CRLF & _
"# Current result:" & @CRLF & _
"# src:'2'" & @CRLF & _
"#" & @CRLF & _
"# Should catch" & @CRLF & _
"# src: '2.3.4.5'" & @CRLF & _
"" & @CRLF & _
"eventAnnotationEndTime=1493293598\=aaa00" & @CRLF & _
"# Should be:" & @CRLF & _
"# eventAnnotationEndTime: '1493293598\=aaa00'" & @CRLF & _
"" & @CRLF & _
"eventAnnotationEndTimeA=1493293598A\=aaa01 " & @CRLF & _
"eventAnnotationEndTimeB=1493293598\=aaa02" & @CRLF & _
"# Should be:" & @CRLF & _
"# eventAnnotationEndTimeA: '1493293598\=aaa01'" & @CRLF & _
"# eventAnnotationEndTimeB: '1493293598\=aaa02'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sourceTranslatedZoneURI=/All Zones/ArcSight System/Private Address Space Zones/RFC1918: 172.3.0.0-172.3.255.255" & @CRLF & _
"# Should be:" & @CRLF & _
"# ourceTranslatedZoneURI: '/All Zones/ArcSight System'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")