$re = '/^EC[0-9]{6}$/m';
$str = 'EC1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);