const regex = /\b[2-9]\d{3}\s\d{4}\s\d{4}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[2-9]\\d{3}\\s\\d{4}\\s\\d{4}\\b', 'gm')
const str = `MR HI Government He PIHe9 Hanumana Ji 3-� fafer/ DOB : 01/01/1959 989 / Male 2094 7051 9541 ������ - ��� ����� �� 3�1���`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}